Amazon – Error:please check Amazon seller account status and billing

Problem

Amazon Sync returns the following error message:

"Error:please check Amazon seller account status and billing"

Cause

The error usually occurs when Amazon has found a problem with your account or is missing important payment information. 

Solution

  • Check your seller central account info and performance notifications for any issues you may need to resolve.
  • Amazon’s Seller Central website has information about Charge Methods and Bank Account that you can check here.
  • Check out any Amazon notifications here that might be relevant.
  • Contact the Seller Support Team to resolve the issue with your account.

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